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Oldalszerkezet – AP elemek , menü k, megjelenítők

Ebben a fejezetben folytatjuk az oldalszerkezet kialakításához használható módsze-
rek megismerését az abszolút pozicionálású elemekkel. Ezzel a módszerrel tudunk 
olyan oldalszerkezeteket kialakítani, amelyek elég rugalmasak és korszerűek ahhoz, 
hogy kielégítsék napjainkban a webszájtokkal szemben támasztott igényeket.
Az első részben megismerkedünk az abszolút pozicionálású (AP) elemek felépíté-
sével, alapvető tulajdonságaival, és azok kezelésével a Dreamweaver által nyújtott 
vizuális eszközök segítségével.

A második részben folytatjuk az abszolút pozicionálású (AP) elemek kezelésének 
megismerését, azon keresztül, hogy a táblázatokkal egyszer már létrehozott szer-
kezetet létrehozzuk AP elemek segítségével is. Itt már kizárólag CSS szabályokban 
adjuk meg az elemek pozícióját és egyéb tulajdonságait, teljesen pontos oldalszer-
kezetet kialakítva ezzel.

A későbbi fejezetekben az itt kialakított oldalszerkezetet fogjuk használni és a 
további oldalak alapjául venni.

A fejezet harmadik részében a példa menüjének kialakításán keresztül megtanul-
juk, hogyan lehet az oldalunkon egérre reagáló elemeket létrehozni pusztán CSS 
szabályok felhasználásával.

A negyedik, befejező részben már megtapasztalhatjuk azt a rugalmasságot, ame-
lyet az AP elemekkel kialakított oldalszerkezet lehetővé tesz: az oldal kódjának 
módosítása nélkül, csupán CSS szabályok használatával létre fogjuk hozni oldalunk 
„nyomtatóbarát” verzióját, valamint annak kézi eszközökön (elsősorban mobiltele-
fonokon) rendesen megjeleníthető verzióját is.

Abszolút pozicionálású elemek  használata

Az abszolút pozicionálású (AP) elemek olyan összetevői a HTML oldalaknak, 
amelyekhez abszolút pozíciót rendeltünk. Ezeket az elemeket általában <div> 
címk ével hozzuk létre, de tulajdonképpen bármely más oldalelem, például egy kép 
is AP elemmé válik, amennyiben abszolút pozíciót rendelünk hozzá CSS szabályok 
segítségével. Az AP elemeket akár úgy is elképzelhetjük, hogy azok egymástól 
független, önálló, az oldalon bárhová elhelyezhető táblázatcellák.

A modern webszájtok készítése során a tervezőknek érdemes CSS alapú, AP ele-
meket használó oldalszerkezeteket készíteniük. Az így elkészített oldalszerkezetek 
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kevesebb sávszélességet használnak, jobban illeszkednek a webes szabványokhoz, és 
könnyebben kezelhetőek hosszú távon.

Az AP elemeket használó, CSS alapú oldalszerkezetek alapvetően két elemből állnak: 
egy sor HTML címkéből, jellemzően <div > címkéből, amelyek a tartalmi blokkokat 
határolják és az oldal alapját adják, valamint egy sor hozzájuk kapcsolódó CSS sza-
bályból, amelyek meghatározzák azok elhelyezkedését, méretét és viselkedését.

Egy <div> címkékkel határolt tartalmi blokkokból álló oldalt úgy képzeljünk 
el, mintha rendelkezésünkre állna egy sor változtatható méretű írásvetítő fólia, 
amelyekre egyenként az oldal egyes elemeit – fejlécet, logót, főcímet, menüt, 
törzsszöveget – helyezzük, majd azokat a képernyőn tetszőleges helyen, sorrendben 
helyezhetünk el. Ezeket a tartalmi blokkokat – a Dreamweaver elnevezésének 
megfelelően – AP Div elemeknek fogjuk nevezni a fejezet során.

Ahogy korábban is említettük, nem csak az abszolút pozicionálású <div> címkékkel 
meghatározott rétegek lehetnek AP elemek, hanem bármely más olyan elem is, 
például egy kép, amelyhez abszolút pozíciót rendeltünk egy CSS szabályban.

A Dreamweaver nagymértékben megkönnyíti, hogy AP elemek segítségével készítsük 
el oldalunk szerkezetét. Míg korábban az oldal kódja alapján sok-sok próbálgatás után 
lehetett csak kialakítani ilyen oldalszerkezeteket, a program integráltan támogatja ezek 
kezelését, és kézenfekvő eszközöket biztosít az AP elemek pozicionálásához, sorrendjé-
nek meghatározásához, elrejtéséhez, megjelenítéséhez és formázásához.

A legnagyobb előny természetesen az, hogy a szerkesztőfelület Design nézetben meg-
lehetősen pontos képet nyújt arról, hogy az oldalunk végül miként fog megjelenni a 
böngészőben, és ezzel a meglehetősen pontos vizuális reprezentációval dolgozhatunk 
végig, nem kell folyamatosan a kód és a böngészőbeli előnézet között váltogatnunk.

Minden előnyével együtt azért tartsuk szem előtt, hogy a Dreamweaver által nyúj-
tott oldalkép csak meglehetősen pontos, és munkánk során ellenőrizzük gyakran, hogy 
a legelterjedtebb böngészőkben is úgy jelenik-e meg, ahogyan azt elképzeltük.
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Az AP Elements panel 

Az oldalon szereplő összes AP elem áttekintéséhez az alapvető eszközünk az AP 
Elements panel. Ez alapértelmezésben a jobboldali panelgyűjtőben található, a CSS 
gyűjtőpanelen, de a Window > AP Elements  menüpont vagy az [F2] gyorsbillentyű 
leütésével előhívható, ha éppen nem látszik a munkafelületen.

Az AP Elements panelen a dokumentumunkban szereplő összes AP elem megje-
lenik, méghozzá egy praktikus faszerkezetben, amely megmutatja, hogy az egyes 
elemek hogyan kapcsolódnak egymáshoz. Az ábrán látható szerkezet a példaszájt 
szerkezetét mutatja, a rész végére ezt fogjuk elkészíteni.

A dokumentum törzsében elhelyezett AP elemek a legfelső szinten jelennek meg, ezek 
pozíciója a dokumentum bal felső sarkához viszonyítva adható meg. Mint azt az ábra 
is mutatja, az AP elemek egymásba ágyazhatóak, tehát egy-egy AP elemen belül létre-
hozhatunk további AP elemeket. Ezen elemek szülője az őket tartalmazó AP elem lesz, 
és pozíciójuk is a szülőjükhöz képest van megadva a rájuk vonatkozó CSS szabályban.

Az ábra szerint tehát a dokumentum törzséhez kapcsolódik egy „befoglalo” elne-
vezésű AP elem, majd az tartalmazza a „fejlec” elnevezésűt, amely további három 
AP elemet tartalmaz („tetejehorgony”, „focim”, „logo”). Szintén a „befoglalo” AP elem 
tartalmazza a „tartalom” és a „menu” AP elemeket.

Alapértelmezésben az elemek z-index ük fordított sorrendjében vannak felsorolva a 
panelen. A z-index, mint ahogyan azt már érintettük a CSS tulajdonságok áttekinté-
sénél, azt határozza meg, hogy az egyes AP elemek a weboldal képzeletbeli függőle-
ges tengelyén hol helyezkednek el: minél nagyobb ez a szám, annál közelebb van az 
olvasóhoz az adott elem, minél kisebb, annál közelebb van az oldal síkjához (0).

A magasabb z-index-szel rendelkező elemek tehát az alacsonyabb (vagy meg nem határo-
zott) z-index-szel rendelkező elemek fölött helyezkednek el, és el is takarhatják azokat.
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Az elemek sorrendjét az AP Elements panelen fogd-és-vidd módszerrel meg-
változtathatjuk: a feljebb vagy lejjebb helyezni kívánt elemre kattintsunk az 
egérrel, majd az egérgomb lenyomva tartása mellett húzzuk a kívánt pozícióba, 
és ott engedjük fel az egérgombot.

A fenti módszerrel csak az AP elemek függőleges sorrendjét változtatjuk meg. Ha a 
[Control] (Windows), illetve [Command] (Macintosh) billentyű lenyomva tartása 
mellett húzunk egy AP elemet új pozícióba, akkor azt egy másikba ágyazhatjuk, 
elég a kívánt elem fölött elengednünk azt.

A függőleges sorrendet a z-index közvetlen átírásával is megváltoztathatjuk, ehhez 
kattintsunk a Z fejlécű oszlopban a számra egyszer, majd írjuk azt át a kívánt értékre.

A bal oldali oszlopban (  ) az egyes AP elemek láthatóságát állíthatjuk be, 
három lépésben. Ha nincs az adott mellett semmi, akkor azon elem szülője lát-
hatóságát örökli. Ha egy nyitott szem (  ) van az elem mellett, akkor látható 
lesz a szülő láthatóságától függetlenül, ha pedig egy csukott szem (  ), akkor 
nem lesz látható, a szülő láthatóságától függetlenül. Az egyes állapotok között úgy 
válthatunk, hogy az oszlopban a módosítani kívánt elem mellett kattintunk, amíg a 
kívánt állapotot jelző ikon (vagy annak hiánya) meg nem jelenik.

A panel tetején található Prevent overlaps jelölőnégyzet bejelölése esetén a Dreamwe-
aver a Design nézetben az AP elemek egérrel történő mozgatásakor, átméretezésekor 
nem fogja megengedni, hogy azok egymásra lógjanak. Ugyanezt a beállítást a Modify 
> Arrange > Prevent AP Element Overlaps menüponttal is megtehetjük. Azt tartsuk 
azonban fejben, hogy ez csak az egérrel történő módosításokra érvényes, a CSS sza-
bályokban illetve a Properties panelen továbbra is megadhatunk olyan pozicionálási és 
méretezési értékeket az oldalon szereplő AP elemeknek, hogy azok egymásra lógjanak.

AP elemek létrehozás a és módosítása vizuális eszközökkel

A Dreamweaver az általa létrehozott AP elemeket mind abszolút pozícionálású 
<div> címkékként hozza létre, úgy, hogy egy egyedi azonosítóval (id) létrehoz 
a dokumentum törzsében (<body>) egy <div> címkét, a dokumentum fejlécében 
pedig egy, a <div> címke azonosítójához kötött CSS szabályt. Az ilyen oldaleleme-
ket a továbbiakban a Dreamweaver szóhasználatának megfelelően AP Div  elemek-
nek fogjuk mi is nevezni.

A Dreamweaver a fenti eljárással lehetővé teszi, hogy oldalunkon könnyedén elhelyez-
zünk AP Div elemeket. Ha az alább leírtakat egyből ki is szeretnénk próbálni a prog-
ramban, érdemes egy, a példához nem kapcsolódó új, üres dokumentumot létrehoznunk. 
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Egy vagy több AP Div elem beszúrásához tehát a következő lépéseket kövessük:

1. Helyezzük a szövegkurzort arra a helyre, ahol az oldalon a <div> címkét 
el szeretnénk helyezni. Tartsuk fejben, hogy ez nem feltétlenül az AP Div 
megjelenési helye, hanem az a hely, ahol az oldal forráskódjában szerepelni 
fog maga a HTML címke.

2. Nyomjuk meg az Insert panelen a Layout kategóriában az AP Div beszúrása (  
– Insert AP Div) gombot, vagy válasszuk a menüből az Insert > Layout Objects > 
AP Div menüpontot.

3. Vigyük vissza az egérkurzort a szerkesztőfelület fölé (Design nézet), ahol az egy 
kis kereszt lesz a szokásos nyíl vagy szövegkijelölő helyett. Az AP Div kívánt 
megjelenítési helyénél egyszerűen csak rajzoljuk meg a megfelelő méretű 
dobozt a szerkesztőfelületen az egérgomb lenyomva tartása mellett:

Egyszerre több AP Div elemet is megrajzolhatunk, ha rajzolásuk alatt lenyomva 
tartjuk a [Control] (Windows), illetve [Command] (Macintosh) billentyűt.

Amikor beszúrunk egy AP Div elemet, akkor a Dreamweaver alapértelmezésben 
megjeleníti a szerkesztőfelület Design nézetén annak kereteit. Ha ezt nem szeretnénk, 
akkor a View > Visual Aids menüpont alatt kapcsoljuk ki az AP Element Outlines és 
a CSS Layout Outlines (AP elemek és CSS oldalszerkezet körvonalai) opciókat.
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Egy AP Div elembe tartalmat úgy vihetünk fel, mint a dokumentum bármely más 
pontjába, a szövegkurzor behelyezésével:

Ilyenkor az AP Div elemet kiemeli a Dreamweaver, de nem jelöli azt ki. Magának 
az AP Div elemnek kijelöléséhez kattintsunk bárhol annak a keretére vagy a bal 
felső sarokban található fülre:

             

 A már létrehozott AP Div elemeinket kijelölés után egyszerűen átméretez-
hetjük a kis négyzetekkel jelölt fogópontok egérrel történő áthúzásával (ezen 
felületek fölött az egérkurzor az átméretezés lehetséges irányainak megfele-
lően kétirányú nyíllá változik).
 
Az AP Div elemeket szabadon át is helyezhetjük, annak keretének vagy fülének 
megfogásával (ezek fölött a felületek fölött az egérkurzor a fenti ábrán látható 
négyirányú nyílra vált át).

Azt is tartsuk fejben, hogy a Dreamweaver az ilyen módon létrehozott AP Div 
elemeket “apDiv” + sorszám azonosítóval hozza létre. A Properties panel bal felső 
sarkában található mezőben ezt megváltoztathatjuk, és a Dreamweaver az adott 
elem méretezéséhez és pozícionálásához létrehozott CSS szabályt nevét is ennek 
megfelelően módosítani fogja a dokumentum fejlécében.
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Egymásba ágyazott AP elemek 

Az egymásba ágyazott AP elemek az olyanok, ahol az egyik elem címkepárja az 
oldal HMTL kódjában a másik elem címkepárján belül jelenik meg. 
A következő kódrészletben az egyes és kettes AP Div elem egymástól független, 
míg a négyes a hármasba van ágyazva:

<div id=”apDiv1”></div>
<div id=”apDiv2”></div>
<div id=”apDiv3”>
 <div id=”apDiv4”></div>
</div>

Az egymásba ágyazott táblázatoktól eltérően egy beágyazott AP Div nem fel-
tétlenül az azt tartalmazó AP Div felületén belül jelenik meg vizuálisan, hiszen 
ez attól függ, hogy hová helyeztük el őket az oldalon belül. Akkor mégis mi 
a haszna az AP Div elemek egymásba ágyazásának? A beágyazott AP elemek 
tulajdonságainak megadásakor az őket tartalmazó AP elem bal felső sarka lesz 
az origó, és ezáltal a szülővel együtt fognak mozogni, valamint láthatóságukat is 
az őket befoglaló elemtől örökölhetik. Ez a viselkedés lehetővé teszi az AP Div 
elemek praktikus csoportosítását.

Alapértelmezésben a Dreamweaver mindig független AP Div elemeket hoz létre, 
ha az előző részben megismert módszerrel, az egérrel rajzoljuk meg őket. Ha mégis 
beágyazott AP Div elemet szeretnénk létrehozni, akkor azt egy meglévő AP Div 
felületére rajzoljuk meg, úgy, hogy közben lenyomva tartjuk az [Alt] (Windows), 
illetve [Option] (Macintosh) billentyűt.

Ha tudjuk, hogy elsősorban egymásba ágyazott AP Div elemekkel szeretnénk dol-
gozni, akkor ellenőrizzük, hogy az AP Elements panelen (Window > AP Elements) 
nincs kiválasztva a Prevent overlaps opció, majd az Edit > Preferences (Macintoshon 
a Dreamweaver > Preferences) menüpontban elérhető párbeszédablakban az AP 
Elements kategóriában kapcsoljuk be a Nesting (beágyazás) opciót. Ezután, ha a 
szerkesztőfelületen egy meglévő AP Div felületén belül rajzolunk meg egy újat, 
akkor az automatikusan a meglévőbe lesz ágyazva.

Figyeljünk oda arra, hogy az egyes böngészőkben eltérően jelenhetnek meg az 
egymásba ágyazott AP Div elemek, ezért gyakran ellenőrizzük munkánkat minél 
többféle böngészőben.
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AP elemekhez kapcsolódó beállítások 

A Preferences párbeszédablak AP Elements kategóriájában meg tudjuk változtatni 
a létrehozandó AP elemek alapértelmezett tulajdonságait. A párbeszédablak meg-
jelenítéséhez válasszuk az Edit > Preferences (Windows), illetve a Dreamweaver > 
Preferences (Macintosh) menüpontot, majd válasszuk ki az AP Elements kategóriát.

A Visibility (láthatóság) legördülő menüben megadhatjuk a létrehozandó AP 
elemek alapértelmezett láthatóságát. A Width (szélesség) és Height (magasság) 
mezőkben az Insert > Layout Objects > AP Div menüpont kiválasztásával létreho-
zott AP Div elemek alapértelmezett méretét állíthatjuk be. A Background color 
(háttérszín) és Background image (háttérkép) mezőkben az AP Div elemek alapér-
telmezett hátterét szabályozhatjuk.

Mint azt már említettük az előző részben, a Nesting (egymásba ágyazás) opció bekap-
csolásával azt érhetjük el, hogy ha a szerkesztőfelületen egy meglévő AP Div felüle-
tén belül rajzolunk meg egy újat, akkor az automatikusan a meglévőbe lesz ágyazva.

A Netscape 4 Compatibility  (Netscape 4 kompatibilitás ) jelölőnégyzet beállításával arra 
kérjük a programot, hogy AP Div elemek használata esetén mindig hozzon létre az 
oldal fejlécében egy olyan kis JavaScript programrészletet, amely megakadályozza, 
hogy ha a Netscape 4-es böngészőt használó látogatók (számuk várhatóan elenyésző) 
átméretezik a böngészőablakot, akkor az AP elemek elveszítsék a megadott helyüket 
azáltal, hogy újratölti az oldalt a böngészőablak minden átméretezésekor.

A Preferences párbeszédablak Invisible Elements  kategóriájában is van egy fontos, 
AP elemekre vonatkozó beállítás. Az Anchor Points For AP elements (horgonyok 
mutatása AP elemek esetén) opció bekapcsolásakor a Dreamweaver a szerkesztőfe-
lület Design nézetében kis  ikonokkal jelezni fogja az AP Div elemeket defi niáló 
HTML címkék tulajdonképpeni elhelyezkedését az oldal kódjában, attól függetle-
nül, hogy maguk az AP Div elemek vizuálisan hol helyezkednek el:
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A kis  ikonokra kattintva kijelölhetjük a hozzájuk tartozó AP Div elemet.

Oldalszerkezet kialakítása AP elemekkel 

Most, hogy az AP Div elemek kezeléséhez az alapvető, Dreamweaver által nyújtott 
vizuális eszközökkel megismerkedtünk, neki is láthatunk a példaszájt oldalszerke-
zetének kialakításához AP Div elemek segítségével.

Mindenképpen érdemes ebben a részben végigkövetni a példát, mert a későbbi-
ekben a most kialakított oldalszerkezettel fogunk dolgozni. Tesszük ezt egyrészt 
azért, mert manapság egyre jobban megkövetelik a weboldalak szerkesztőitől, 
hogy táblázatok helyett AP elemekkel alakítsák ki az oldalak szerkezetét, más-
részt pedig azért, mert a későbbiekben ez a szerkezet sokkal nagyobb rugalmas-
ságot fog biztosítani nekünk ahhoz, hogy a szokásos megjelenítőktől (számítógép 
és teljes méretű monitor) eltérő eszközökre (konkrétan nyomtatásra és mobiltele-
fonokra) külön oldalváltozatok elkészítése nélkül, pusztán stíluslapok segítségével 
optimalizáljuk elkészített oldalunkat.

DWkonyv_07_oldalszerkezet_2_new.167   167DWkonyv_07_oldalszerkezet_2_new.167   167 2007.09.30.   21:33:032007.09.30.   21:33:03



168 Dreamweaver CS3
 EGYSZERŰEN

Dw

Előkészítés

Ebben a részben megint csak egy új dokumentummal fogunk dolgozni, ez a későbbi-
ekben ténylegesen a példaszájt nyitóoldala lesz majd. Tartalmában megegyezik 
a korábbi fejezetek során használt „alapok.html” dokumentummal, azonban annak tar-
talmát csak a szerkezet kialakítása közben fogjuk átmásolni az új dokumentumunkba.

Ellenőrizzük, hogy a Files panelen valóban példaszájtunkkal dolgozunk, majd első 
lépésként a példaszájt gyökérkönyvtárában hozzunk létre egy „index-ap.html” elne-
vezésű dokumentumot. Válasszuk ki a File > New…(Fájl > Új...) menüpontot, majd 
hozzunk létre egy HTML típusú, <none> szerkezettel rendelkező új dokumentumot:

Ennek hatására meg fog jelenni a szerkesztőfelületen egy teljesen új dokumentum. 
Mielőtt továbbmennénk, mentsük el dokumentumunkat. A mentéshez üssük le 
a [Ctrl]+[S] gyorsbillentyűt, vagy válasszuk ki a menüből a File > Save… parancsot, 
majd a párbeszédablakban a példaszájt gyökérkönyvtárába mentsük el az új, üres 
dokumentumot „index-ap.html” néven.

A következő lépésben adjuk meg az oldal címét, amely később a böngésző címsorá-
ban is megjelenik majd, a szerkesztőfelület eszköztárában található Title szövegme-
zőben („8mm – régi idők házimozija”):
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Az utolsó előkészítő lépésben logikus lenne azt feltételezni, hogy a címen kívüli 
egyéb oldaltulajdonságokat kell megadnunk. Ez részben így is van, de már nem kell 
a Page properties párbeszédablakot használnunk, hiszen az „alapok.html” szerkesz-
tésénél ezeket már megadtuk egyszer. Az oldaltulajdonságokat meghatározó összes 
CSS szabályt az „alapertelmezett.css” külső stíluslapban tároljuk, a táblázatos 
oldalszerkezet kialakítása során létrehozott szabályokkal egyetemben.

Ugyan el fogunk ettől térni, de első lépésben társítsuk ezt a stíluslapot új doku-
mentumunkhoz, mégpedig a CSS Styles panelen a  (Attach Style Sheet – stílus-
lap csatolása) gomb megnyomásával, vagy a Text > CSS Styles > Attach Style Sheet 
menüpont kiválasztásával.

A megjelenő párbeszédablakban a „css” könyvtárból válasszuk ki az „alapertelme-
zett.css” stíluslapot. Ennek hatására egyrészt az abban tárolt stílusok megjelennek 
a CSS Styles panelen, másrészt pedig a szerkesztőfelületen az „index.html” doku-
mentum formázását innentől kezdve ez a stíluslap határozza meg.

A következő lépésben hozzunk létre egy új stíluslapot, hogy az eddigi, táblázatok-
hoz kialakított stílusaink ne vesszenek el. Azokat a szabályokat, amelyekre az AP 
elemekkel kialakított oldalszerkezetnél is szükségünk van, át fogjuk másolni 
az “alapertelmezett.css” stíluslapból az újba.

Új stíluslap létrehozásához válasszuk ki a File > New…(Fájl > Új...) menüpontot, majd 
keressük ki a CSS tételt a Page Type oszlopból, végül nyomjuk meg a Create gombot:
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Ennek hatására meg fog jelenni a szerkesztőfelületen egy új, üres CSS dokumentum. 
Ezt mentsük el a példaszájt „css” könyvtárába „monitor.css” néven. A mentéshez üssük 
le a [Ctrl]+[S] gyorsbillentyűt, vagy válasszuk ki a menüből a File > Save… parancsot, 
majd a párbeszédablakban a példaszájt „css” könyvtárába mentsük el az új, üres CSS 
dokumentumot „monitor.css” néven. A dokumentumot zárjuk is be, szerkesztéséhez a 
továbbiakban a Dreamweaver CSS kezelő eszközeit fogjuk használni.

Ahhoz, hogy ezt megtehessük, a következő lépésben társítsuk ezt az új stíluslapot 
is új dokumentumunkhoz, mégpedig a CSS Styles panelen a  (Attach Style Sheet 
– stíluslap csatolása) gomb megnyomásával, vagy a Text > CSS Styles > Attach Style 
Sheet menüpont kiválasztásával (fi gyeljünk oda, hogy a szerkesztőfelületen az 
„index-ap.html” dokumentum legyen megjelenítve).

A megjelenő párbeszédablakban a „css” könyvtárból válasszuk ki a „monitor.css” 
stíluslapot, majd nyomjuk meg az OK gombot. Ennek hatására a CSS Styles panelen 
megjelenik ez a stíluslap is:

      

A következő lépésben az „alapertelmezett.css” stíluslapból átmásoljuk a szükséges 
szabályokat az új, „monitor.css” stíluslapba, majd töröljük a régi stíluslap társítását.
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  1  2  3  4

        

1. Jelöljük ki a „p”, „body,td,th”, „a:link”, „h1”, „h2”, „img”, „.tetejere,” és a „.tetejere img” 
szabályokat. Több szabályt egyszerre a [Control] (Windows), illetve [Command] 
(Macintosh) billentyű lenyomva tartása mellett történő kattintással jelölhetünk 
ki. Ezután fogjuk meg az egérrel a kijelölt szabályokat, majd húzzuk át őket a 
[Control] (Windows), illetve [Command] (Macintosh) billentyű lenyomva tartása 
mellett (hogy másolat készüljön belőlük) a „monitor.css” alatti üres felületre.

2. Ezzel át is másoltuk a folytatáshoz szükséges szabályokat új stíluslapunkba.

3. Jelöljük ki az „alapertelmezett.css” stíluslapot, majd nyomjuk meg a CSS Styles 
panel jobb alsó sarkában található  (Delete… – Törlés) gombot.

4. Ezzel el is távolítottuk az „alapertelmezett.css” stíluslap társítását dokumentumunk-
ból, és a továbbiakban csak a „monitor.css” stíluslappal fogunk dolgozni.

Ha a táblázatokkal való munka során hasznosnak találtuk, állítsunk be most is 
nyugodtan oldalképet a háttérben:

1. Válasszuk a View > Tracing Image > Load… menüpontot, vagy a Modify > Page 
Properties menüpontot, vagy a Properties panelen nyomjuk meg a Page Properties… 
gombot. Az utóbbi két esetben nyomjuk meg a Tracing image kategóriában 
a Tracing Image szövegmező mellett található Browse… (Windows), illetve 
Choose (Macintosh) gombot.

2. A megjelenő párbeszédablakban válasszuk ki az oldalképként használni kívánt kép-
állományt. A példához ezt a példaszájt állományai között, az „egyeb” könyvtárban, 
„8mm.jpg” néven találjuk. Ezt a fájlt nem kell bemásolni a szájt könyvtárszerkeze-
tébe (meg fogja kérdezni a Dreamweaver, hogy be szeretnénk-e oda másolni).
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3. A következő lépésben megjelenik a Page Properties párbeszédablak, úgy, hogy 
a Tracing Image kategória látható, ahol a csúszkával megadhatjuk annak az 
áttetszőségét (minél alacsonyabb az érték, az eredetihez képest annál halvá-
nyabban fog megjelenni az oldalkép a háttérben). Válasszuk a 25%-ot, most 
sokkal fontosabb jól látnunk a fölötte elhelyezett elemeket, mint a táblázatok-
kal kialakított oldalszerkezet esetén.

4. Igazítsuk az oldalképet a bal felső sarokhoz úgy, hogy az állapotsorban 
a címkeválasztó segítségével kijelöljük a <body> címkét, majd kiválasztjuk a 
View > Tracing Image > Align with Selection menüpontot.

Ha jónak látjuk, a pozícionálás további megkönnyítéséhez állítsunk be egy vízszin-
tes segédvonalat 64 pixelhez (a felső vonalzóról lehúzva azt), illetve egy függőlege-
set 140 pixelhez (a bal oldali vonalzóról lehúzva azt).

Ha oldalképet és segédvonalakat is beállítottunk, a következő ábrán látható kör-
nyezetben kezdhetünk neki munkánknak:
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